Can't connect

Questions, comments, suggestions, and bug reports
Nightmaress
Member
Posts: 27
Joined: Thu Nov 03, 2011 2:52 am
antispam: rimor

Can't connect

Postby Nightmaress » Wed Sep 13, 2017 1:30 am

I seem to be having an issue connecting my bot for some reason. It seems to be an endless loop of

"PHP Warning: log4php: [LoggerAppenderDailyFile:defaultFileAppender]: Failed opening target file. Closing appender. in C:\Users\Mothership\Desktop\Budabot3.5_RC1\lib\vendor\apache\log4php\src\main\php\LoggerAppender.php on line 283
2017-09-13 01:24:45 INFO Starting Intercomm (3.5_RC1) on RK5...

Warning: log4php: [LoggerAppenderDailyFile:defaultFileAppender]: Failed opening target file. Closing appender. in C:\Users\Mothership\Desktop\Budabot3.5_RC1\lib\vendor\apache\log4php\src\main\php\LoggerAppender.php on line 283
2017-09-13 01:24:45 INFO Loading CORE modules...
2017-09-13 01:24:46 INFO Loading USER modules...
PHP Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY000]: General error: 8 attempt to write a readonly database' in C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\DB.class.php:145
Stack trace:
#0 C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\DB.class.php(145): PDOStatement->execute()
#1 C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\DB.class.php(117): Budabot\Core\DB->executeQuery('UPDATE cmdcfg_i...', Array)
#2 C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\Budabot.class.php(91): Budabot\Core\DB->exec('UPDATE cmdcfg_<...')
#3 C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\BotRunner.php(74): Budabot\Core\Budabot->init(Array)
#4 C:\Users\Mothership\Desktop\Budabot3.5_RC1\main.php(6): Budabot\Core\BotRunner->run()
#5 {main}

Next exception 'Budabot\Core\SQLException' with message 'attempt to write a readonly database in: UPDATE cmdcfg_intercomm SET `verify` = 0 - Array
(
)
' in C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\DB.class.php:152
Stack trace:
#0 C:\Users\Mothership\Desktop\Budabot3.5_RC in C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\DB.class.php on line 152

Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY000]: General error: 8 attempt to write a readonly database' in C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\DB.class.php:145
Stack trace:
#0 C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\DB.class.php(145): PDOStatement->execute()
#1 C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\DB.class.php(117): Budabot\Core\DB->executeQuery('UPDATE cmdcfg_i...', Array)
#2 C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\Budabot.class.php(91): Budabot\Core\DB->exec('UPDATE cmdcfg_<...')
#3 C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\BotRunner.php(74): Budabot\Core\Budabot->init(Array)
#4 C:\Users\Mothership\Desktop\Budabot3.5_RC1\main.php(6): Budabot\Core\BotRunner->run()
#5 {main}

Next exception 'Budabot\Core\SQLException' with message 'attempt to write a readonly database in: UPDATE cmdcfg_intercomm SET `verify` = 0 - Array
(
)
' in C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\DB.class.php:152
Stack trace:
#0 C:\Users\Mothership\Desktop\Budabot3.5_RC in C:\Users\Mothership\Desktop\Budabot3.5_RC1\core\DB.class.php on line 152
"

I have tried older bots of mine and even tried to reinstall but no luck. Any thoughts?
Tyrence
Posts: 1933
Joined: Sat Jan 09, 2010 1:32 am

Re: Can't connect

Postby Tyrence » Wed Sep 13, 2017 3:42 am

It looks like the user you are running Budabot as does not have write privileges on the directory since the error log seems to indicate that Budabot can neither write to the log file or the database.
"Those who expect to reap the blessings of freedom, must, like men, undergo the fatigues of supporting it." — Thomas Paine
"Nearly all men stand adversity, but if you want to test a man's character, give him power." — Abraham Lincoln
Budabot Releases and Downloads: https://github.com/Budabot/Budabot/releases
Nightmaress
Member
Posts: 27
Joined: Thu Nov 03, 2011 2:52 am
antispam: rimor

Re: Can't connect

Postby Nightmaress » Fri Sep 15, 2017 2:04 am

Any idea how to correct this?
Tyrence
Posts: 1933
Joined: Sat Jan 09, 2010 1:32 am

Re: Can't connect

Postby Tyrence » Fri Sep 15, 2017 4:41 am

Hmmm, not really. If it's on your desktop, there is no reason your user shouldn't have write privileges there. Maybe copy it somewhere else and see if that makes a difference? Or right click on the Budabot folder and make sure "Read only" is not checked and that you have write permissions on it.
"Those who expect to reap the blessings of freedom, must, like men, undergo the fatigues of supporting it." — Thomas Paine
"Nearly all men stand adversity, but if you want to test a man's character, give him power." — Abraham Lincoln
Budabot Releases and Downloads: https://github.com/Budabot/Budabot/releases
Nightmaress
Member
Posts: 27
Joined: Thu Nov 03, 2011 2:52 am
antispam: rimor

Re: Can't connect

Postby Nightmaress » Sat Sep 16, 2017 4:37 pm

Sadly none of those ideas worked :( it's weird because I haven't changed anything guess I will just fiddle around and hope for the best
Nightmaress
Member
Posts: 27
Joined: Thu Nov 03, 2011 2:52 am
antispam: rimor

Re: Can't connect

Postby Nightmaress » Sat Sep 16, 2017 9:01 pm

Next time I will check my antivirus first. Problem solved :ugeek:

Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest