AO Chat Proxy Setup for orgs with 1K+ members

Questions, comments, suggestions, and bug reports
Phare
Member
Posts: 5
Joined: Fri May 01, 2015 5:41 pm
antispam: Rimor

Re: AO Chat Proxy Setup for orgs with 1K+ members

Postby Phare » Fri May 15, 2015 5:07 pm

I though its becouse im running it on Centos, but Krypto seems he use Centos too.

I disabled Firewall and try'd without too but same error.
I have a dedicated server. There is no way i miss resources for it, my server have 32 GB RAM and is running with SSD's on mysql and files also it has 1Gbit connection.
From what we tested, Krypto dont get disconnects but the orglist to 1k+ guild returns 0 members online when there are 20+, so maybe is not 100% functional when you check with orgs that have 1k+ members? I dont know anymore :)

Anyway look the whole error below:


Code: Select all

2015-05-15 16:41:12,063 ERROR [clientHandler] (ClientHandler.scala:64) - java.lang.IllegalStateException: Queue full
2015-05-15 16:41:19,753  INFO [main] (AOConnection.java:100) - mainbot shutting down.
2015-05-15 16:41:20,110 ERROR [chatPacketListener] (ChatPacketListener.java:45) - Bot Character: 'mainbot' packet id: '-1'
java.lang.NullPointerException
        at java.io.ByteArrayInputStream.<init>(ByteArrayInputStream.java:106)
        at com.jkbff.ao.tyrlib.packets.BaseServerPacket.createInstance(BaseServerPacket.java:34)
        at com.jkbff.ao.tyrlib.chat.ChatPacketListener.run(ChatPacketListener.java:38)
2015-05-15 16:41:24,754  INFO [main] (AOConnection.java:100) - slave1 shutting down.
2015-05-15 16:41:24,770 ERROR [chatPacketListener] (ChatPacketListener.java:45) - Bot Character: 'Slave1' packet id: '-1'
java.lang.NullPointerException
        at java.io.ByteArrayInputStream.<init>(ByteArrayInputStream.java:106)
        at com.jkbff.ao.tyrlib.packets.BaseServerPacket.createInstance(BaseServerPacket.java:34)
        at com.jkbff.ao.tyrlib.chat.ChatPacketListener.run(ChatPacketListener.java:38)
2015-05-15 16:41:29,755  INFO [main] (Program.scala:43) - Ready to accept a master bot on port 9993
2015-05-15 16:41:32,250  INFO [clientHandler] (ClientHandler.scala:114) - starting proxy bot main
2015-05-15 16:41:32,251  INFO [clientHandler] (ClientHandler.scala:114) - starting proxy bot slave1
Tyrence
Posts: 1959
Joined: Sat Jan 09, 2010 1:32 am

Re: AO Chat Proxy Setup for orgs with 1K+ members

Postby Tyrence » Fri Jul 31, 2015 4:22 pm

I am working on a new version of the AOChatProxy that should fix this issue as well as several others, but development has been slow due to the complex nature of that code and I am still working on it.
"Those who expect to reap the blessings of freedom, must, like men, undergo the fatigues of supporting it." — Thomas Paine
"Nearly all men stand adversity, but if you want to test a man's character, give him power." — Abraham Lincoln
Budabot Releases and Downloads: https://github.com/Budabot/Budabot/releases
Intyl
Member
Posts: 60
Joined: Tue Sep 27, 2011 8:06 pm
antispam: Rimor

Re: AO Chat Proxy Setup for orgs with 1K+ members

Postby Intyl » Mon Sep 21, 2015 8:08 am

Bump - I too got this error. So I thought it just was an AOChat proxy error.. Disabled the aoChat and just run the bot. NOt getting error messages from the bot bot it reloads again and again, and again...

Edit: Read your analysis and that might be why mine looks the same. SO my ROOT problem is that the bot restarts over and aover again. Causing the AOchat to expose its bug..
Datch1
Member
Posts: 13
Joined: Sun Dec 14, 2014 4:34 pm
antispam: Rimor

Re: AO Chat Proxy Setup for orgs with 1K+ members

Postby Datch1 » Sun Jan 10, 2016 11:42 pm

Hi all,
I'm trying to start aochatproxy on my linux server and it keeps coming up with fiald to execute child process "/Bots/aochatproxy1.1/start.sh" (no such file or directory). Start.sh is there so I asume it's trying to start something else. So what am I missing?

Datch
Tyrence
Posts: 1959
Joined: Sat Jan 09, 2010 1:32 am

Re: AO Chat Proxy Setup for orgs with 1K+ members

Postby Tyrence » Tue Jan 12, 2016 6:36 am

How are you trying to start it?
"Those who expect to reap the blessings of freedom, must, like men, undergo the fatigues of supporting it." — Thomas Paine
"Nearly all men stand adversity, but if you want to test a man's character, give him power." — Abraham Lincoln
Budabot Releases and Downloads: https://github.com/Budabot/Budabot/releases
Datch1
Member
Posts: 13
Joined: Sun Dec 14, 2014 4:34 pm
antispam: Rimor

Re: AO Chat Proxy Setup for orgs with 1K+ members

Postby Datch1 » Sun Jan 17, 2016 9:01 pm

Yes, I'm trying to run it in a terminal window with the Start.sh file and it keeps saying the same thing
Tyrence
Posts: 1959
Joined: Sat Jan 09, 2010 1:32 am

Re: AO Chat Proxy Setup for orgs with 1K+ members

Postby Tyrence » Thu Jan 21, 2016 9:05 am

I'm not sure. I might try downloading it again and seeing if that fixes it.
"Those who expect to reap the blessings of freedom, must, like men, undergo the fatigues of supporting it." — Thomas Paine
"Nearly all men stand adversity, but if you want to test a man's character, give him power." — Abraham Lincoln
Budabot Releases and Downloads: https://github.com/Budabot/Budabot/releases
Datch1
Member
Posts: 13
Joined: Sun Dec 14, 2014 4:34 pm
antispam: Rimor

Re: AO Chat Proxy Setup for orgs with 1K+ members

Postby Datch1 » Sat Jan 23, 2016 10:11 pm

I tried downloading again. still the same thing - the download runs ok on the windows PC - say waiting for master bot - but it won't run on my linux server. Am i being really stupid and missing something in the setup or should it just run?

Datch
Tyrence
Posts: 1959
Joined: Sat Jan 09, 2010 1:32 am

Re: AO Chat Proxy Setup for orgs with 1K+ members

Postby Tyrence » Sat Jan 23, 2016 11:06 pm

Have you installed Java on your server? Run "java -version" and then paste the contents.
"Those who expect to reap the blessings of freedom, must, like men, undergo the fatigues of supporting it." — Thomas Paine
"Nearly all men stand adversity, but if you want to test a man's character, give him power." — Abraham Lincoln
Budabot Releases and Downloads: https://github.com/Budabot/Budabot/releases
liquidzoo
Member
Posts: 3
Joined: Fri Dec 01, 2017 9:30 pm
antispam: Rimor

Re: AO Chat Proxy Setup for orgs with 1K+ members

Postby liquidzoo » Fri Dec 01, 2017 9:42 pm

I hate to bump this, but I'm having an issue.

Trying to run this to run both an org and a proxy bot. Nothing seems to work...

Org bot fires up just fine and runs well, but with the proxy it seems something's not right.

Inside chatbot.peoperties I have this at the start:

Code: Select all

proxyPortNumber=9993
serverAddress=chat.d1.funcom.com
serverPortNumber=7105


Followed by the 2 bot names/accounts.

So far so good (unless that's the wrong chat server address?)

Fire it up and I see:

Code: Select all

...
INFO [main] (Program.scala:44) - Ready to accept a proxy connection on port 9993


I should note that this is not like any other instances I've seen... It's ALWAYS said (based on other code chunks) ...:43 - ...Ready for master bot (or something like that).

When I try to start my bot, it says "Waiting 10 seconds for AOChatProxy to reset" followed by an error stating "Someone else logging on to same account?)"

No one is logging on, I'm not sure what the issue is.

This is with the zip file linked at the top of this thread. I know there are newer commits that have been made to the 2 other branches, but I'm not sure if they have made it into that file or not. I don't see anywhere else that has a complete download to try in case I have an old version.

Any thoughts? I hope this is still being read. I will provide any info I can to help.

Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest